<!doctype html><html>

<head>
<script type="text/javascript">
var autoslide_time = 10000;
</script>
    
	
<!-- MapPress Easy Google Maps Version:2.48.7 (https://www.mappresspro.com) -->
<script type='text/javascript'>mapp = window.mapp || {}; mapp.data = [];</script>
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ReGen Magazine &raquo; Trash Deity, featuring WaxTrax! veterans Groovie Mann and JDN, announces debut album Comments Feed" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/regenmag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.7"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mappress-css'  href='https://regenmag.com/wp-content/plugins/mappress-google-maps-for-wordpress/css/mappress.css?ver=2.48.7' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://regenmag.com/wp-content/themes/londoncreative4_2/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://regenmag.com/wp-includes/css/dashicons.min.css?ver=4.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-widget-social-icons-styles-css'  href='https://regenmag.com/wp-content/plugins/jetpack/modules/widgets/social-icons/social-icons.css?ver=20170506' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='https://regenmag.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://regenmag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://regenmag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://regenmag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://regenmag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://regenmag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://regenmag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://regenmag.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='CONFORMCO InterView: Opposing the Elite' href='https://regenmag.com/interviews/conformco-interview-opposing-the-elite/' />
<meta name="generator" content="WordPress 4.9.7" />
<link rel="canonical" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/" />
<link rel='shortlink' href='https://wp.me/p3tXfy-7QW' />
<link rel="alternate" type="application/json+oembed" href="https://regenmag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fregenmag.com%2Fnews%2Ftrash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://regenmag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fregenmag.com%2Fnews%2Ftrash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.12.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript" src="https://regenmag.com/wp-content/plugins/audio-player/assets/audio-player.js?ver=2.0.4.6"></script>
<script type="text/javascript">AudioPlayer.setup("https://regenmag.com/wp-content/plugins/audio-player/assets/player.swf?ver=2.0.4.6", {width:"290",animation:"yes",encode:"yes",initialvolume:"60",remaining:"no",noinfo:"no",buffer:"5",checkpolicy:"no",rtl:"no",bg:"E5E5E5",text:"333333",leftbg:"CCCCCC",lefticon:"333333",volslider:"666666",voltrack:"FFFFFF",rightbg:"B4B4B4",rightbghover:"999999",righticon:"333333",righticonhover:"FFFFFF",track:"FFFFFF",loader:"009900",border:"CCCCCC",tracker:"DDDDDD",skip:"666666",pagebg:"FFFFFF",transparentpagebg:"yes"});</script>
<style type="text/css">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</style>
	
	<!-- Added by EventCalendar plugin. Version 3.1.4 -->
	<script type='text/javascript' src='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/xmlhttprequest.js'></script>
	<script type='text/javascript' src='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/ec3.js'></script>
	<script type='text/javascript'><!--
	ec3.start_of_week=1;
	ec3.month_of_year=new Array('January','February','March','April','May','June','July','August','September','October','November','December');
	ec3.month_abbrev=new Array('Jan','Feb','Mar','Apr','May','Jun','Jul','Aug','Sep','Oct','Nov','Dec');
	ec3.myfiles='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53';
	ec3.home='http://regenmag.com';
	ec3.hide_logo=0;
	ec3.viewpostsfor="View posts for %1$s %2$s";
	// --></script>

<style type='text/css' media='screen'>
@import url(http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/ec3.css);
.ec3_ec {
 background-image:url(http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/ec.png) !IMPORTANT;
 background-image:none;
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/ec.png');
}
#ec3_shadow0 {
 background-image:url(http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/shadow0.png) !IMPORTANT;
 background-image:none;
}
#ec3_shadow0 div {
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/shadow0.png',sizingMethod='scale');
}
#ec3_shadow1 {
 background-image:url(http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/shadow1.png) !IMPORTANT;
 background-image:none;
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/shadow1.png',sizingMethod='crop');
}
#ec3_shadow2 {
 background-image:url(http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/shadow2.png) !IMPORTANT;
 background-image:none;
}
#ec3_shadow2 div {
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://regenmag.com/wp-content/plugins/event-calendar-3-for-php-53/shadow2.png',sizingMethod='scale');
}
</style>

<!-- <meta name="NextGEN" version="3.0.1" /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<script type="text/javascript" src="https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1533245391"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->

<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Trash Deity, featuring WaxTrax! veterans Groovie Mann and JDN, announces debut album" />
<meta property="og:url" content="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/" />
<meta property="og:description" content="&nbsp; Nearly two years after the project&#8217;s formation, Los Angeles duo Trash Deity has announced the release of its debut album, Cross &amp; Divide, via Metropolis Records. The collaboration …" />
<meta property="article:published_time" content="2018-08-02T15:01:05+00:00" />
<meta property="article:modified_time" content="2018-08-02T15:01:05+00:00" />
<meta property="og:site_name" content="ReGen Magazine" />
<meta property="og:image" content="http://regenmag.com/wp-content/uploads/2018/08/TrashDeityBanner2.jpg" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@regenmag" />
<meta name="twitter:text:title" content="Trash Deity, featuring WaxTrax! veterans Groovie Mann and JDN, announces debut album" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@regenmag" />

<!-- End Jetpack Open Graph Tags -->
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-547282-1', 'auto');
 
	ga('send', 'pageview');
</script>
   <!--[if lt IE 7.]>
    <script ype="text/javascript" src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/DD_belatedPNG.js"></script>
    <script>

    DD_belatedPNG.fix('#search input.field, #search input.field:focus, #featured_home .bigimg .post_category,#featured_home .bigimg .post_name a, #message_buttons .button2 a, #message_buttons .button2 a:hover, #inner_content .date, img');
    </script>
  <![endif]-->    
<script type="text/javascript" src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/jquery.rotate.js"></script>
<script type="text/javascript" src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/contact.js"></script>

<script src="https://regenmag.com/wp-content/themes/londoncreative4_2/skins/custom/js/dropdown.js" type="text/javascript"></script>

<script src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/jquery.preload.js" type="text/javascript"></script>
  
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>Trash Deity, featuring WaxTrax! veterans Groovie Mann and JDN, announces debut album &laquo;  ReGen Magazine</title>
  <link rel="stylesheet" type="text/css" href="https://regenmag.com/wp-content/themes/londoncreative4_2/style.css"/>
  <link rel="stylesheet" type="text/css" href="https://regenmag.com/wp-content/themes/londoncreative4_2/skins/custom/custom.css"/>
  <link rel="stylesheet" type="text/css" href="https://regenmag.com/wp-content/themes/londoncreative4_2/sliders/slider_freshcubes.css"/>
  
  <link rel="stylesheet" href="https://regenmag.com/wp-content/themes/londoncreative4_2/css/prettyPhoto.css" type="text/css" media="screen" charset="utf-8" />

<script src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/jquery.prettyPhoto.js" type="text/javascript" charset="utf-8"></script>
<link rel="stylesheet" href="https://regenmag.com/wp-content/themes/londoncreative4_2/css/prettyPhoto.css" type="text/css" media="screen" charset="utf-8" />



	<link rel="pingback" href="https://regenmag.com/xmlrpc.php" /> 
  
		<link rel='archives' title='August 2018' href='https://regenmag.com/2018/08/' />
	<link rel='archives' title='July 2018' href='https://regenmag.com/2018/07/' />
	<link rel='archives' title='June 2018' href='https://regenmag.com/2018/06/' />
	<link rel='archives' title='May 2018' href='https://regenmag.com/2018/05/' />
	<link rel='archives' title='April 2018' href='https://regenmag.com/2018/04/' />
	<link rel='archives' title='March 2018' href='https://regenmag.com/2018/03/' />
	<link rel='archives' title='February 2018' href='https://regenmag.com/2018/02/' />
	<link rel='archives' title='January 2018' href='https://regenmag.com/2018/01/' />
	<link rel='archives' title='December 2017' href='https://regenmag.com/2017/12/' />
	<link rel='archives' title='November 2017' href='https://regenmag.com/2017/11/' />
	<link rel='archives' title='October 2017' href='https://regenmag.com/2017/10/' />
	<link rel='archives' title='September 2017' href='https://regenmag.com/2017/09/' />
	<link rel='archives' title='August 2017' href='https://regenmag.com/2017/08/' />
	<link rel='archives' title='July 2017' href='https://regenmag.com/2017/07/' />
	<link rel='archives' title='June 2017' href='https://regenmag.com/2017/06/' />
	<link rel='archives' title='May 2017' href='https://regenmag.com/2017/05/' />
	<link rel='archives' title='April 2017' href='https://regenmag.com/2017/04/' />
	<link rel='archives' title='March 2017' href='https://regenmag.com/2017/03/' />
	<link rel='archives' title='February 2017' href='https://regenmag.com/2017/02/' />
	<link rel='archives' title='January 2017' href='https://regenmag.com/2017/01/' />
	<link rel='archives' title='December 2016' href='https://regenmag.com/2016/12/' />
	<link rel='archives' title='November 2016' href='https://regenmag.com/2016/11/' />
	<link rel='archives' title='October 2016' href='https://regenmag.com/2016/10/' />
	<link rel='archives' title='September 2016' href='https://regenmag.com/2016/09/' />
	<link rel='archives' title='August 2016' href='https://regenmag.com/2016/08/' />
	<link rel='archives' title='July 2016' href='https://regenmag.com/2016/07/' />
	<link rel='archives' title='June 2016' href='https://regenmag.com/2016/06/' />
	<link rel='archives' title='May 2016' href='https://regenmag.com/2016/05/' />
	<link rel='archives' title='April 2016' href='https://regenmag.com/2016/04/' />
	<link rel='archives' title='March 2016' href='https://regenmag.com/2016/03/' />
	<link rel='archives' title='February 2016' href='https://regenmag.com/2016/02/' />
	<link rel='archives' title='January 2016' href='https://regenmag.com/2016/01/' />
	<link rel='archives' title='December 2015' href='https://regenmag.com/2015/12/' />
	<link rel='archives' title='November 2015' href='https://regenmag.com/2015/11/' />
	<link rel='archives' title='October 2015' href='https://regenmag.com/2015/10/' />
	<link rel='archives' title='September 2015' href='https://regenmag.com/2015/09/' />
	<link rel='archives' title='August 2015' href='https://regenmag.com/2015/08/' />
	<link rel='archives' title='July 2015' href='https://regenmag.com/2015/07/' />
	<link rel='archives' title='June 2015' href='https://regenmag.com/2015/06/' />
	<link rel='archives' title='May 2015' href='https://regenmag.com/2015/05/' />
	<link rel='archives' title='April 2015' href='https://regenmag.com/2015/04/' />
	<link rel='archives' title='March 2015' href='https://regenmag.com/2015/03/' />
	<link rel='archives' title='January 2015' href='https://regenmag.com/2015/01/' />
	<link rel='archives' title='December 2014' href='https://regenmag.com/2014/12/' />
	<link rel='archives' title='November 2014' href='https://regenmag.com/2014/11/' />
	<link rel='archives' title='October 2014' href='https://regenmag.com/2014/10/' />
	<link rel='archives' title='September 2014' href='https://regenmag.com/2014/09/' />
	<link rel='archives' title='August 2014' href='https://regenmag.com/2014/08/' />
	<link rel='archives' title='July 2014' href='https://regenmag.com/2014/07/' />
	<link rel='archives' title='June 2014' href='https://regenmag.com/2014/06/' />
	<link rel='archives' title='May 2014' href='https://regenmag.com/2014/05/' />
	<link rel='archives' title='April 2014' href='https://regenmag.com/2014/04/' />
	<link rel='archives' title='March 2014' href='https://regenmag.com/2014/03/' />
	<link rel='archives' title='February 2014' href='https://regenmag.com/2014/02/' />
	<link rel='archives' title='January 2014' href='https://regenmag.com/2014/01/' />
	<link rel='archives' title='December 2013' href='https://regenmag.com/2013/12/' />
	<link rel='archives' title='November 2013' href='https://regenmag.com/2013/11/' />
	<link rel='archives' title='October 2013' href='https://regenmag.com/2013/10/' />
	<link rel='archives' title='September 2013' href='https://regenmag.com/2013/09/' />
	<link rel='archives' title='August 2013' href='https://regenmag.com/2013/08/' />
	<link rel='archives' title='July 2013' href='https://regenmag.com/2013/07/' />
	<link rel='archives' title='June 2013' href='https://regenmag.com/2013/06/' />
	<link rel='archives' title='May 2013' href='https://regenmag.com/2013/05/' />
	<link rel='archives' title='April 2013' href='https://regenmag.com/2013/04/' />
	<link rel='archives' title='March 2013' href='https://regenmag.com/2013/03/' />
	<link rel='archives' title='February 2013' href='https://regenmag.com/2013/02/' />
	<link rel='archives' title='January 2013' href='https://regenmag.com/2013/01/' />
	<link rel='archives' title='December 2012' href='https://regenmag.com/2012/12/' />
	<link rel='archives' title='November 2012' href='https://regenmag.com/2012/11/' />
	<link rel='archives' title='October 2012' href='https://regenmag.com/2012/10/' />
	<link rel='archives' title='September 2012' href='https://regenmag.com/2012/09/' />
	<link rel='archives' title='August 2012' href='https://regenmag.com/2012/08/' />
	<link rel='archives' title='July 2012' href='https://regenmag.com/2012/07/' />
	<link rel='archives' title='June 2012' href='https://regenmag.com/2012/06/' />
	<link rel='archives' title='May 2012' href='https://regenmag.com/2012/05/' />
	<link rel='archives' title='April 2012' href='https://regenmag.com/2012/04/' />
	<link rel='archives' title='March 2012' href='https://regenmag.com/2012/03/' />
	<link rel='archives' title='February 2012' href='https://regenmag.com/2012/02/' />
	<link rel='archives' title='January 2012' href='https://regenmag.com/2012/01/' />
	<link rel='archives' title='December 2011' href='https://regenmag.com/2011/12/' />
	<link rel='archives' title='November 2011' href='https://regenmag.com/2011/11/' />
	<link rel='archives' title='October 2011' href='https://regenmag.com/2011/10/' />
	<link rel='archives' title='September 2011' href='https://regenmag.com/2011/09/' />
	<link rel='archives' title='August 2011' href='https://regenmag.com/2011/08/' />
	<link rel='archives' title='July 2011' href='https://regenmag.com/2011/07/' />
	<link rel='archives' title='June 2011' href='https://regenmag.com/2011/06/' />
	<link rel='archives' title='May 2011' href='https://regenmag.com/2011/05/' />
	<link rel='archives' title='April 2011' href='https://regenmag.com/2011/04/' />
	<link rel='archives' title='March 2011' href='https://regenmag.com/2011/03/' />
	

  
 
</head>

<body class="post-template-default single single-post postid-30190 single-format-standard">
<div id="wrapper">
    <div id="border_top"></div><!--  END "border_top"  //-->
    <div id="header" class="clearfix">
        <div id="logo">
        	<a href="https://regenmag.com">
                      <img src="https://regenmag.com/images/regenlogoblue_x100.png" alt="ReGen Magazine" id="lclogo"/>
          </a>
        </div><!--  END "logo"  //-->
        <div id="header_contacts"><a href="http://www.facebook.com/#!/ReGenMag"><img src="http://www.regenmag.com/images/facebook.png"></a><a href="http://twitter.com/#!/regenmag"><img src="http://www.regenmag.com/images/twitter.png"></a><a href="http://www.regenmag.com/feed"><img src="http://www.regenmag.com/images/rss.png"></a></div>
    </div><!--  END "header"  //-->
    <div id="container" class="clearfix">
    	<div id="toppanel" class="clearfix">
            <div id="navigation">
                 <div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="menu"><li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://regenmag.com/category/blog/">Blog</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://regenmag.com/category/concerts/">Concerts</a></li>
<li id="menu-item-1924" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1924"><a href="https://regenmag.com/category/interviews/">Interviews</a></li>
<li id="menu-item-1925" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1925"><a href="https://regenmag.com/category/news/">News</a></li>
<li id="menu-item-341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-341"><a href="https://regenmag.com/category/reviews/">ReViews</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31"><a href="https://regenmag.com/contact/">Contact</a></li>
</ul></div>            </div><!--  END "navigation"  //-->
            <div id="search">
                  <form id="searchform" action="https://regenmag.com" method="get">
                        <div>
                             <input id="s" class="field" type="text" onblur="if (this.value == '') {this.value = 'Enter keywords..';}" onfocus="if (this.value == 'Enter keywords..') {this.value = '';}" value="Enter keywords.." name="s"/>
                             <input class="submit" type="submit" name="submit" value="Search"/>
                        </div>
                  </form>
            </div><!--  END "search"  //-->
            
      </div><!--  END "toppanel"  //-->

        <div id="content_wrap">
          <div id="inner_content">
       
                                        <div class="entry " id="post-30190">
              
                                        <div class="date clearfix">
                        <div class="date_holder">
                            <span class="month">Aug<span class="year"> 2018 </span></span><span class="day">02</span>                        </div><!--  END "date_holder"  //-->
                    </div><!--  END "date"  //-->
                                                                 
                    <div class="title_holder">
                        <h1><a href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/" class="title">Trash Deity, featuring WaxTrax! veterans Groovie Mann and JDN, announces debut album</a><a href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/#respond" class="comment_counter" >0</a></h1>
                        <h3>Posted In <span><a href="https://regenmag.com/category/news/" rel="category tag">News</a></span></h3>
                    </div><!--  END "title_holder"  //-->
                                        <div class="entry_content">
                            	<p><a href="http://regenmag.com/wp-content/uploads/2018/08/TrashDeity_CrossDivide.jpg"><img src="http://regenmag.com/wp-content/uploads/2018/08/TrashDeityBanner2.jpg" alt="Trash Deity, featuring WaxTrax! veterans Groovie Mann and JDN, announces debut album" width="500" height="250" class="aligncenter size-full wp-image-30192" srcset="https://regenmag.com/wp-content/uploads/2018/08/TrashDeityBanner2.jpg 500w, https://regenmag.com/wp-content/uploads/2018/08/TrashDeityBanner2-300x150.jpg 300w" sizes="(max-width: 500px) 100vw, 500px" /></a><br />
&nbsp;<br />
Nearly two years after the project&#8217;s formation, Los Angeles duo Trash Deity has announced the release of its debut album, <em>Cross &#038; Divide</em>, via Metropolis Records. The collaboration of vocalist/lyricist Groovie Mann (a.k.a. Franke N. Nardiello) and producer/musician JDN (a.k.a. John D. Norten), the two veterans of the Chicago WaxTrax! era bridge their collective histories<span id="more-30190"></span> in the guitar driven heavy electronic scene with a modern production sheen. Groovie Mann is best known as the front man for My Life with the Thrill Kill Kult, while JDN esablished himself in Blue Eyed Christ. The band first appeared with the &#8220;Finger on a Trigger&#8221; single in late 2016 with the intention of releasing an EP to be titled <em>Run 4 Your Lies!</em>; the track &#8220;Run 4 Your Lies!&#8221; followed in summer of 2017, with both songs released as singles on iTunes with music videos created by photographer/graphic artist Neil Kull. Both songs will be appearing on <em>Cross &#038; Divide</em>, which is scheduled for release on September 7 and is available for pre-order now via the Metropolis Records <a href="https://www.metropolis-records.com/product/11633/cross-divide">website</a> and <a href="https://trashdeity.bandcamp.com/album/cross-divide">Bandcamp</a>.</p>
<p>&nbsp;</p>
<p>Trash Deity<br />
<a href="https://www.facebook.com/Trashdeity/">Facebook</a>, <a href="https://twitter.com/TrashDeity">Twitter</a>, <a href="https://soundcloud.com/trashdeity">SoundCloud</a>, <a href="https://trashdeity.bandcamp.com">Bandcamp</a>, <a href="https://www.youtube.com/channel/UCUr-kFogKc6KtWR16aejOig">YouTube</a><br />
Metropolis Records<br />
<a href="http://www.metropolis-records.com">Website</a>, <a href="http://www.facebook.com/MetropolisRecords">Facebook</a>, <a href="http://www.twitter.com/metropolisrec">Twitter</a>, <a href="http://metropolisrecords.bandcamp.com">Bandcamp</a>, <a href="https://www.youtube.com/user/MetropolisRecords">YouTube</a><br />
&nbsp;<br />
Ilker Yücel (Ilker81x)</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-30190" class="share-facebook sd-button share-icon no-text" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/?share=facebook" rel="noopener noreferrer" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-30190" class="share-twitter sd-button share-icon no-text" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/?share=twitter" rel="noopener noreferrer" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow" data-shared="sharing-google-30190" class="share-google-plus-1 sd-button share-icon no-text" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/?share=google-plus-1" rel="noopener noreferrer" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/?share=tumblr" rel="noopener noreferrer" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://regenmag.com/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/?share=reddit" rel="noopener noreferrer" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>                                                  </div><!--  END "entry_content"  //-->
                    <div class="comments">
                    
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	 


<div id="respond">

<h3>Leave a Comment</h3>

<div class="cancel-comment-reply">
	<small><a rel="nofollow" id="cancel-comment-reply-link" href="/news/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album/#respond" style="display:none;">Click here to cancel reply.</a></small>
</div>


<form action="http://regenmag.com/wp-comments-post.php" method="post" id="commentform">


<p><input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
<label for="author"><small>Name (required)</small></label></p>

<p><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' />
<label for="email"><small>Mail (will not be published) (required)</small></label></p>

<p><input type="text" name="url" id="url" value="" size="22" tabindex="3" />
<label for="url"><small>Website</small></label></p>


<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->

<p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
<input type='hidden' name='comment_post_ID' value='30190' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="3921420293" /></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_comments" id="subscribe_comments" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-label" for="subscribe_comments">Notify me of follow-up comments by email.</label></p><p class="comment-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto; -moz-appearance: checkbox; -webkit-appearance: checkbox;" /> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog">Notify me of new posts by email.</label></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="208"/></p>
<div id="captchaImgDiv">

<div class="si_captcha_small"><img id="si_image_com" src="https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix=ok4CqHChpZzE8HQW" width="132" height="45" alt="CAPTCHA" title="CAPTCHA" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="ok4CqHChpZzE8HQW" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix='); return false;">
      <img class="si_captcha_refresh" src="https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh" onclick="this.blur();" /></a>
  </div>
  </div>

<p id="si_captcha_code_p">
<input id="si_captcha_code" name="si_captcha_code" type="text" />
<label for="si_captcha_code" >CAPTCHA Code</label><span class="required"> *</span>
</p>
</div>
      <script type='text/javascript'>
          var sUrlInput = document.getElementById("comment");
                  var oParent = sUrlInput.parentNode;
          var sSubstitue = document.getElementById("captchaImgDiv");
                  oParent.appendChild(sSubstitue, sUrlInput);
      </script>
            <noscript>
          <style type='text/css'>#submit {display:none;}</style><br />           <input name="submit" type="submit" id="submit-alt" tabindex="6" value="Submit Comment" />
          </noscript>
  
</form>


</div>
                    </div>
              </div><!--  END "entry"  //-->
 

            
          </div><!--  END "inner_content"  //-->
          
     
        
          <div id="sidebar_home">
          <div class="widget">	<h3 class="widget_title">Advertisement</h3><div class="g g-1"><div class="g-single a-55"><a href="https://metropolisrecords.bandcamp.com/" target="_blank"><img src="http://regenmag.com/wp-content/gallery/ads/4.MetlogoBW300x400Regen.jpg" /></a></div></div></div><div class="widget">	<h3 class="widget_title">Newsletter</h3><script>(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><!-- MailChimp for WordPress v4.2.3 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-20737 mc4wp-form-basic" method="post" data-id="20737" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><center>
	<h2>Sign Up for the ReGen Newsletter:</h2>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
<br>
<p>
	<input type="submit" value="Submit" />
</p>
</center></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1533245391" /><input type="hidden" name="_mc4wp_form_id" value="20737" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / MailChimp for WordPress Plugin --></div><div class="widget">	<h3 class="widget_title">Donate to Regen</h3><p>ReGen is a 100% volunteer run publication. However, there are costs involved in running a website - we need your help! Please donate so that we may continue to provide the best possible content to ReGenerate Your Mind!</p>
<!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="ilker@regenmag.com" />
        <input type="hidden" name="item_name" value="If you enjoy our content, please consider making a donation to ReGen to assist us in covering expenses. We are a 100% volunteer run publication." />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donate_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" />
    </div>
</form>
<!-- End PayPal Donations -->
</div><div class="widget">	<h3 class="widget_title">Recent ReViews</h3><ul id="category-posts-15-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/reviews/front-line-assembly-warmech/" rel="bookmark">Front Line Assembly &#8211; WarMech</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/reviews/pig-risen/" rel="bookmark">PIG &#8211; Risen</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/reviews/xorcist-legion/" rel="bookmark">Xorcist &#8211; Legion</a></div></li></ul>
</div><div class="widget">	<h3 class="widget_title">Recent Inteviews</h3><ul id="category-posts-16-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/interviews/conformco-interview-opposing-the-elite/" rel="bookmark">CONFORMCO InterView: Opposing the Elite</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/interviews/xibling-interview-catharsis-connection-revolution/" rel="bookmark">Xibling InterView: Catharsis. Connection. rEvolution.</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/interviews/pig-interview-high-on-the-hog/" rel="bookmark">PIG InterView: High on the Hog</a></div></li></ul>
</div><div class="widget">	<h3 class="widget_title">Recent News</h3><ul id="category-posts-17-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/autumn-announces-u-s-tour-in-support-of-comeback-album/" rel="bookmark">Autumn announces U.S. tour in support of comeback album</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/david-j-announces-solo-u-k-dates-tour-with-peter-murphy-to-celebrate-bauhaus-40th-anniversary/" rel="bookmark">David J. announces solo U.K. dates, tour with Peter Murphy to celebrate Bauhaus&#8217; 40th anniversary</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/devin-townsend-announces-second-in-vinyl-box-set-series/" rel="bookmark">Devin Townsend announces second in vinyl box set series</a></div></li></ul>
</div><div class="widget">	<h3 class="widget_title">Recent Blogs</h3><ul id="category-posts-18-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/blog/skatenigs-chant-evil-kunst-live-in-18/" rel="bookmark">Skatenigs/CHANT/Evil Kunst Live in ‘18</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/blog/photo-gallery-ministry-chelsea-wolfe-the-god-bombs-in-baltimore-md/" rel="bookmark">Photo Gallery &#8211; MINISTRY/Chelsea Wolfe/The God Bombs in Baltimore, MD</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/blog/severed-nations-in-kansas-city/" rel="bookmark">Severed Nations in Kansas City</a></div></li></ul>
</div>  
          </div><!--  END "sidebar_home"  //-->
          
    
        </div><!--  END "content_wrap"  //-->
    </div><!--  END "container"  //-->


<div id="footer" class="clearfix">
    <div id="footer_left"></div>
    <div id="footer_right"><a href="https://regenmag.com"><img src="http://regenmag.com/images/regenlogoblue_x35.png" alt="ReGen Magazine" /></a></div>
</div>
<div id="footer_bottom" class="clearfix"></div><!--  END "footer"  //-->

</div><!--  END "wrapper"  //-->
<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://regenmag.com/wp-includes/js/comment-reply.min.js?ver=4.9.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/regenmag.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/regenmag.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201831'></script>
<script type='text/javascript' src='https://regenmag.com/wp-includes/js/wp-embed.min.js?ver=4.9.7'></script>
<script async="async" type='text/javascript' src='https://regenmag.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.8'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.2.3'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.2.3'></script>
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.3.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<a rel="nofollow" style="display:none;" href="https://regenmag.com/?blackhole=de731feb5e" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script>(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/regenmag.com\/news\/trash-deity-featuring-waxtrax-veterans-groovie-mann-and-jdn-announces-debut-album\/":30190};
	</script>
<script type='text/javascript' src='https://stats.wp.com/e-201831.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.3.2',blog:'51468280',post:'30190',tz:'-4',srv:'regenmag.com'} ]);
	_stq.push([ 'clickTrackerInit', '51468280', '30190' ]);
</script>
 
</body>
</html>
