<!doctype html><html>

<head>
<script type="text/javascript">
var autoslide_time = 10000;
</script>
    
	
<!-- MapPress Easy Google Maps Version:2.54.6 (http://www.mappresspro.com/mappress) -->
<script type='text/javascript'>mapp = window.mapp || {}; mapp.data = [];</script>

	<!-- This site is optimized with the Yoast SEO plugin v14.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>InterView: Jim Semonik – Reflecting and Forging New Paths - ReGen Magazine</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="InterView: Jim Semonik – Reflecting and Forging New Paths" />
	<meta property="og:description" content="One of the scene&#8217;s hardest working and most unifying figures, Jim Semonik speaks with ReGen about his latest creative output. &nbsp; &nbsp; An InterView with Jim Semonik of Distortion Productions and Red Lokust By Ilker Yücel (Ilker81x) Jim Semonik can truly be considered one of the patron saints of the modern industrial and harsh electro [&hellip;]" />
	<meta property="og:url" content="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/" />
	<meta property="og:site_name" content="ReGen Magazine" />
	<meta property="article:publisher" content="https://www.facebook.com/ReGenMag" />
	<meta property="article:published_time" content="2020-08-06T20:08:16+00:00" />
	<meta property="og:image" content="https://regenmag.com/wp-content/uploads/2020/08/JimSemonikBanner.jpg" />
	<meta property="og:image:width" content="525" />
	<meta property="og:image:height" content="250" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:title" content="InterView: Jim Semonik – Reflecting and Forging New Paths" />
	<meta name="twitter:image" content="https://regenmag.com/wp-content/uploads/2020/08/JimSemonikBanner.jpg" />
	<meta name="twitter:creator" content="@regenmag" />
	<meta name="twitter:site" content="@regenmag" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://regenmag.com/#organization","name":"ReGen Magazine","url":"https://regenmag.com/","sameAs":["https://www.facebook.com/ReGenMag","https://twitter.com/regenmag"],"logo":{"@type":"ImageObject","@id":"https://regenmag.com/#logo","inLanguage":"en-US","url":"https://regenmag.com/wp-content/uploads/2011/03/regenlogo.jpg","width":"500","height":"141","caption":"ReGen Magazine"},"image":{"@id":"https://regenmag.com/#logo"}},{"@type":"WebSite","@id":"https://regenmag.com/#website","url":"https://regenmag.com/","name":"ReGen Magazine","description":"Industrial, synthpop, electronic, alternative music","publisher":{"@id":"https://regenmag.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://regenmag.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#primaryimage","inLanguage":"en-US","url":"https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikBanner.jpg"},{"@type":"WebPage","@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#webpage","url":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/","name":"InterView: Jim Semonik \u2013 Reflecting and Forging New Paths - ReGen Magazine","isPartOf":{"@id":"https://regenmag.com/#website"},"primaryImageOfPage":{"@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#primaryimage"},"datePublished":"2020-08-06T20:08:16+00:00","dateModified":"2020-08-06T20:08:16+00:00","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/"]}]},{"@type":"Article","@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#article","isPartOf":{"@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#webpage"},"author":{"@id":"https://regenmag.com/#/schema/person/b0c41f925181ea86942bcae302efb4a3"},"headline":"InterView: Jim Semonik \u2013 Reflecting and Forging New Paths","datePublished":"2020-08-06T20:08:16+00:00","dateModified":"2020-08-06T20:08:16+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#webpage"},"publisher":{"@id":"https://regenmag.com/#organization"},"image":{"@id":"https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#primaryimage"},"articleSection":"Interviews,slider","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#respond"]}]},{"@type":["Person"],"@id":"https://regenmag.com/#/schema/person/b0c41f925181ea86942bcae302efb4a3","name":"Ilker Y\u00fccel","image":{"@type":"ImageObject","@id":"https://regenmag.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e1f7165a7fd4c5184e8cad1b0e7a2f72?s=96&d=mm&r=g","caption":"Ilker Y\u00fccel"},"description":"Ilker Y\u00fccel joined ReGen in summer 2004 after his myriad of music reviews on Amazon.com caught the attention of the staff. He is responsible for writing ReViews and InterViews and overseeing editorial aspects of the site. He has also been a Legislator Research Analyst at Vocus Inc. since 1998 where he is responsible for maintaining a National Legislator Database. Ilker graduated from the University of Maryland at College Park in December of 2002 with a B.A. in Art Studio, concentrating on Graphic Design. He is also a part-time musician, playing guitar and synthesizers in various musical projects in the Baltimore/DC area."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/regenmag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='simple_music_widget_styles-css'  href='https://regenmag.com/wp-content/plugins/simple-music-widget/css/style.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://regenmag.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mappress-leaflet-css'  href='https://regenmag.com/wp-content/plugins/mappress-google-maps-for-wordpress/css/leaflet/leaflet.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='mappress-css'  href='https://regenmag.com/wp-content/plugins/mappress-google-maps-for-wordpress/css/mappress.css?ver=2.54.6' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-basic-css'  href='https://regenmag.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-basic.min.css?ver=4.7.8' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='https://regenmag.com/wp-content/themes/londoncreative4_2/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_singlepic_style-css'  href='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_singlepic/static/nextgen_basic_singlepic.css?ver=3.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://regenmag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=8.6.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://regenmag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.6.1' type='text/css' media='all' />
<script type='text/javascript' src='https://regenmag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://regenmag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4'></script>
<link rel='https://api.w.org/' href='https://regenmag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://regenmag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://regenmag.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://wp.me/p3tXfy-avp' />
<link rel="alternate" type="application/json+oembed" href="https://regenmag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fregenmag.com%2Finterviews%2Finterview-jim-semonik-reflecting-and-forging-new-paths%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://regenmag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fregenmag.com%2Finterviews%2Finterview-jim-semonik-reflecting-and-forging-new-paths%2F&#038;format=xml" />

<!-- This site is using AdRotate v5.8.4 to display their advertisements - https://ajdg.solutions/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px 1px 1px 1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<style>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</style>
	<!-- <meta name="NextGEN" version="3.3.5" /> -->

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<script type="text/javascript" src="https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1596766903"></script>
<!-- begin SI CAPTCHA Anti-Spam - login/register form style -->
<style type="text/css">
.si_captcha_small { width:175px; height:45px; padding-top:10px; padding-bottom:10px; }
.si_captcha_large { width:250px; height:60px; padding-top:10px; padding-bottom:10px; }
img#si_image_com { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_reg { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_log { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_side_login { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_checkout { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_jetpack { border-style:none; margin:0; padding-right:5px; float:left; }
img#si_image_bbpress_topic { border-style:none; margin:0; padding-right:5px; float:left; }
.si_captcha_refresh { border-style:none; margin:0; vertical-align:bottom; }
div#si_captcha_input { display:block; padding-top:15px; padding-bottom:5px; }
label#si_captcha_code_label { margin:0; }
input#si_captcha_code_input { width:65px; }
p#si_captcha_code_p { clear: left; padding-top:10px; }
.si-captcha-jetpack-error { color:#DC3232; }
</style>
<!-- end SI CAPTCHA Anti-Spam - login/register form style -->
<!-- Google Analytics Tracking by Google Analyticator 6.5.4: http://www.videousermanuals.com/google-analyticator/ -->
<script type="text/javascript">
    var analyticsFileTypes = [''];
    var analyticsSnippet = 'disabled';
    var analyticsEventTracking = 'enabled';
</script>
<script type="text/javascript">
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-547282-1', 'auto');
 
	ga('send', 'pageview');
</script>
   <!--[if lt IE 7.]>
    <script ype="text/javascript" src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/DD_belatedPNG.js"></script>
    <script>

    DD_belatedPNG.fix('#search input.field, #search input.field:focus, #featured_home .bigimg .post_category,#featured_home .bigimg .post_name a, #message_buttons .button2 a, #message_buttons .button2 a:hover, #inner_content .date, img');
    </script>
  <![endif]-->    
<script type="text/javascript" src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/jquery.rotate.js"></script>
<script type="text/javascript" src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/contact.js"></script>

<script src="https://regenmag.com/wp-content/themes/londoncreative4_2/skins/custom/js/dropdown.js" type="text/javascript"></script>

<script src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/jquery.preload.js" type="text/javascript"></script>
  
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	
  <link rel="stylesheet" type="text/css" href="https://regenmag.com/wp-content/themes/londoncreative4_2/style.css"/>
  <link rel="stylesheet" type="text/css" href="https://regenmag.com/wp-content/themes/londoncreative4_2/skins/custom/custom.css"/>
  <link rel="stylesheet" type="text/css" href="https://regenmag.com/wp-content/themes/londoncreative4_2/sliders/slider_freshcubes.css"/>
  
  <link rel="stylesheet" href="https://regenmag.com/wp-content/themes/londoncreative4_2/css/prettyPhoto.css" type="text/css" media="screen" charset="utf-8" />

<script src="https://regenmag.com/wp-content/themes/londoncreative4_2/js/jquery.prettyPhoto.js" type="text/javascript" charset="utf-8"></script>
<link rel="stylesheet" href="https://regenmag.com/wp-content/themes/londoncreative4_2/css/prettyPhoto.css" type="text/css" media="screen" charset="utf-8" />



	<link rel="pingback" href="https://regenmag.com/xmlrpc.php" /> 
  
		<link rel='archives' title='August 2020' href='https://regenmag.com/2020/08/' />
	<link rel='archives' title='July 2020' href='https://regenmag.com/2020/07/' />
	<link rel='archives' title='June 2020' href='https://regenmag.com/2020/06/' />
	<link rel='archives' title='May 2020' href='https://regenmag.com/2020/05/' />
	<link rel='archives' title='April 2020' href='https://regenmag.com/2020/04/' />
	<link rel='archives' title='March 2020' href='https://regenmag.com/2020/03/' />
	<link rel='archives' title='February 2020' href='https://regenmag.com/2020/02/' />
	<link rel='archives' title='January 2020' href='https://regenmag.com/2020/01/' />
	<link rel='archives' title='December 2019' href='https://regenmag.com/2019/12/' />
	<link rel='archives' title='November 2019' href='https://regenmag.com/2019/11/' />
	<link rel='archives' title='October 2019' href='https://regenmag.com/2019/10/' />
	<link rel='archives' title='September 2019' href='https://regenmag.com/2019/09/' />
	<link rel='archives' title='August 2019' href='https://regenmag.com/2019/08/' />
	<link rel='archives' title='July 2019' href='https://regenmag.com/2019/07/' />
	<link rel='archives' title='June 2019' href='https://regenmag.com/2019/06/' />
	<link rel='archives' title='May 2019' href='https://regenmag.com/2019/05/' />
	<link rel='archives' title='April 2019' href='https://regenmag.com/2019/04/' />
	<link rel='archives' title='March 2019' href='https://regenmag.com/2019/03/' />
	<link rel='archives' title='February 2019' href='https://regenmag.com/2019/02/' />
	<link rel='archives' title='January 2019' href='https://regenmag.com/2019/01/' />
	<link rel='archives' title='December 2018' href='https://regenmag.com/2018/12/' />
	<link rel='archives' title='November 2018' href='https://regenmag.com/2018/11/' />
	<link rel='archives' title='October 2018' href='https://regenmag.com/2018/10/' />
	<link rel='archives' title='September 2018' href='https://regenmag.com/2018/09/' />
	<link rel='archives' title='August 2018' href='https://regenmag.com/2018/08/' />
	<link rel='archives' title='July 2018' href='https://regenmag.com/2018/07/' />
	<link rel='archives' title='June 2018' href='https://regenmag.com/2018/06/' />
	<link rel='archives' title='May 2018' href='https://regenmag.com/2018/05/' />
	<link rel='archives' title='April 2018' href='https://regenmag.com/2018/04/' />
	<link rel='archives' title='March 2018' href='https://regenmag.com/2018/03/' />
	<link rel='archives' title='February 2018' href='https://regenmag.com/2018/02/' />
	<link rel='archives' title='January 2018' href='https://regenmag.com/2018/01/' />
	<link rel='archives' title='December 2017' href='https://regenmag.com/2017/12/' />
	<link rel='archives' title='November 2017' href='https://regenmag.com/2017/11/' />
	<link rel='archives' title='October 2017' href='https://regenmag.com/2017/10/' />
	<link rel='archives' title='September 2017' href='https://regenmag.com/2017/09/' />
	<link rel='archives' title='August 2017' href='https://regenmag.com/2017/08/' />
	<link rel='archives' title='July 2017' href='https://regenmag.com/2017/07/' />
	<link rel='archives' title='June 2017' href='https://regenmag.com/2017/06/' />
	<link rel='archives' title='May 2017' href='https://regenmag.com/2017/05/' />
	<link rel='archives' title='April 2017' href='https://regenmag.com/2017/04/' />
	<link rel='archives' title='March 2017' href='https://regenmag.com/2017/03/' />
	<link rel='archives' title='February 2017' href='https://regenmag.com/2017/02/' />
	<link rel='archives' title='January 2017' href='https://regenmag.com/2017/01/' />
	<link rel='archives' title='December 2016' href='https://regenmag.com/2016/12/' />
	<link rel='archives' title='November 2016' href='https://regenmag.com/2016/11/' />
	<link rel='archives' title='October 2016' href='https://regenmag.com/2016/10/' />
	<link rel='archives' title='September 2016' href='https://regenmag.com/2016/09/' />
	<link rel='archives' title='August 2016' href='https://regenmag.com/2016/08/' />
	<link rel='archives' title='July 2016' href='https://regenmag.com/2016/07/' />
	<link rel='archives' title='June 2016' href='https://regenmag.com/2016/06/' />
	<link rel='archives' title='May 2016' href='https://regenmag.com/2016/05/' />
	<link rel='archives' title='April 2016' href='https://regenmag.com/2016/04/' />
	<link rel='archives' title='March 2016' href='https://regenmag.com/2016/03/' />
	<link rel='archives' title='February 2016' href='https://regenmag.com/2016/02/' />
	<link rel='archives' title='January 2016' href='https://regenmag.com/2016/01/' />
	<link rel='archives' title='December 2015' href='https://regenmag.com/2015/12/' />
	<link rel='archives' title='November 2015' href='https://regenmag.com/2015/11/' />
	<link rel='archives' title='October 2015' href='https://regenmag.com/2015/10/' />
	<link rel='archives' title='September 2015' href='https://regenmag.com/2015/09/' />
	<link rel='archives' title='August 2015' href='https://regenmag.com/2015/08/' />
	<link rel='archives' title='July 2015' href='https://regenmag.com/2015/07/' />
	<link rel='archives' title='June 2015' href='https://regenmag.com/2015/06/' />
	<link rel='archives' title='May 2015' href='https://regenmag.com/2015/05/' />
	<link rel='archives' title='April 2015' href='https://regenmag.com/2015/04/' />
	<link rel='archives' title='March 2015' href='https://regenmag.com/2015/03/' />
	<link rel='archives' title='January 2015' href='https://regenmag.com/2015/01/' />
	<link rel='archives' title='December 2014' href='https://regenmag.com/2014/12/' />
	<link rel='archives' title='November 2014' href='https://regenmag.com/2014/11/' />
	<link rel='archives' title='October 2014' href='https://regenmag.com/2014/10/' />
	<link rel='archives' title='September 2014' href='https://regenmag.com/2014/09/' />
	<link rel='archives' title='August 2014' href='https://regenmag.com/2014/08/' />
	<link rel='archives' title='July 2014' href='https://regenmag.com/2014/07/' />
	<link rel='archives' title='June 2014' href='https://regenmag.com/2014/06/' />
	<link rel='archives' title='May 2014' href='https://regenmag.com/2014/05/' />
	<link rel='archives' title='April 2014' href='https://regenmag.com/2014/04/' />
	<link rel='archives' title='March 2014' href='https://regenmag.com/2014/03/' />
	<link rel='archives' title='February 2014' href='https://regenmag.com/2014/02/' />
	<link rel='archives' title='January 2014' href='https://regenmag.com/2014/01/' />
	<link rel='archives' title='December 2013' href='https://regenmag.com/2013/12/' />
	<link rel='archives' title='November 2013' href='https://regenmag.com/2013/11/' />
	<link rel='archives' title='October 2013' href='https://regenmag.com/2013/10/' />
	<link rel='archives' title='September 2013' href='https://regenmag.com/2013/09/' />
	<link rel='archives' title='August 2013' href='https://regenmag.com/2013/08/' />
	<link rel='archives' title='July 2013' href='https://regenmag.com/2013/07/' />
	<link rel='archives' title='June 2013' href='https://regenmag.com/2013/06/' />
	<link rel='archives' title='May 2013' href='https://regenmag.com/2013/05/' />
	<link rel='archives' title='April 2013' href='https://regenmag.com/2013/04/' />
	<link rel='archives' title='March 2013' href='https://regenmag.com/2013/03/' />
	<link rel='archives' title='February 2013' href='https://regenmag.com/2013/02/' />
	<link rel='archives' title='January 2013' href='https://regenmag.com/2013/01/' />
	<link rel='archives' title='December 2012' href='https://regenmag.com/2012/12/' />
	<link rel='archives' title='November 2012' href='https://regenmag.com/2012/11/' />
	<link rel='archives' title='October 2012' href='https://regenmag.com/2012/10/' />
	<link rel='archives' title='September 2012' href='https://regenmag.com/2012/09/' />
	<link rel='archives' title='August 2012' href='https://regenmag.com/2012/08/' />
	<link rel='archives' title='July 2012' href='https://regenmag.com/2012/07/' />
	<link rel='archives' title='June 2012' href='https://regenmag.com/2012/06/' />
	<link rel='archives' title='May 2012' href='https://regenmag.com/2012/05/' />
	<link rel='archives' title='April 2012' href='https://regenmag.com/2012/04/' />
	<link rel='archives' title='March 2012' href='https://regenmag.com/2012/03/' />
	<link rel='archives' title='February 2012' href='https://regenmag.com/2012/02/' />
	<link rel='archives' title='January 2012' href='https://regenmag.com/2012/01/' />
	<link rel='archives' title='December 2011' href='https://regenmag.com/2011/12/' />
	<link rel='archives' title='November 2011' href='https://regenmag.com/2011/11/' />
	<link rel='archives' title='October 2011' href='https://regenmag.com/2011/10/' />
	<link rel='archives' title='September 2011' href='https://regenmag.com/2011/09/' />
	<link rel='archives' title='August 2011' href='https://regenmag.com/2011/08/' />
	<link rel='archives' title='July 2011' href='https://regenmag.com/2011/07/' />
	<link rel='archives' title='June 2011' href='https://regenmag.com/2011/06/' />
	<link rel='archives' title='May 2011' href='https://regenmag.com/2011/05/' />
	<link rel='archives' title='April 2011' href='https://regenmag.com/2011/04/' />
	<link rel='archives' title='March 2011' href='https://regenmag.com/2011/03/' />
	

  
 
<link rel='stylesheet' id='ngg_trigger_buttons-css'  href='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/static/trigger_buttons.css?ver=3.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='shutter-0-css'  href='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/shutter/shutter.css?ver=3.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome_v4_shim_style-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/v4-shims.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://use.fontawesome.com/releases/v5.3.1/css/all.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_basic_thumbnails_style-css'  href='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/thumbnails/nextgen_basic_thumbnails.css?ver=3.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='nextgen_pagination_style-css'  href='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_pagination/static/style.css?ver=3.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='nggallery-css'  href='https://regenmag.com/wp-content/ngg_styles/nggallery.css?ver=3.3.5' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-40387 single-format-standard">
<div id="wrapper">
    <div id="border_top"></div><!--  END "border_top"  //-->
    <div id="header" class="clearfix">
        <div id="logo">
        	<a href="https://regenmag.com">
                      <img src="https:///regenmag.com/images/regenlogoblue_x100.png" alt="ReGen Magazine" id="lclogo"/>
          </a>
        </div><!--  END "logo"  //-->
        <div id="header_contacts"><a href="http://www.facebook.com/#!/ReGenMag"><img src="https://www.regenmag.com/images/facebook.png"></a><a href="http://twitter.com/#!/regenmag"><img src="https://www.regenmag.com/images/twitter.png"></a><a href="https://www.regenmag.com/feed"><img src="https://www.regenmag.com/images/rss.png"></a></div>
    </div><!--  END "header"  //-->
    <div id="container" class="clearfix">
    	<div id="toppanel" class="clearfix">
            <div id="navigation">
                 <div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="menu"><li id="menu-item-55" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-55"><a href="https://regenmag.com/category/blog/">Blog</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-56"><a href="https://regenmag.com/category/concerts/">Concerts</a></li>
<li id="menu-item-1924" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1924"><a href="https://regenmag.com/category/interviews/">Interviews</a></li>
<li id="menu-item-1925" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1925"><a href="https://regenmag.com/category/news/">News</a></li>
<li id="menu-item-341" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-341"><a href="https://regenmag.com/category/reviews/">ReViews</a></li>
<li id="menu-item-31" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31"><a href="https://regenmag.com/contact/">Contact</a></li>
</ul></div>            </div><!--  END "navigation"  //-->
            <div id="search">
                  <form id="searchform" action="https://regenmag.com" method="get">
                        <div>
                             <input id="s" class="field" type="text" onblur="if (this.value == '') {this.value = 'Enter keywords..';}" onfocus="if (this.value == 'Enter keywords..') {this.value = '';}" value="Enter keywords.." name="s"/>
                             <input class="submit" type="submit" name="submit" value="Search"/>
                        </div>
                  </form>
            </div><!--  END "search"  //-->
            
      </div><!--  END "toppanel"  //-->

        <div id="content_wrap">
          <div id="inner_content">
       
                                        <div class="entry " id="post-40387">
              
                                        <div class="date clearfix">
                        <div class="date_holder">
                            <span class="month">Aug<span class="year"> 2020 </span></span><span class="day">06</span>                        </div><!--  END "date_holder"  //-->
                    </div><!--  END "date"  //-->
                                                                 
                    <div class="title_holder">
                        <h1><a href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/" class="title">InterView: Jim Semonik – Reflecting and Forging New Paths</a><a href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#respond" class="comment_counter" >0</a></h1>
                        <h3>Posted In <span><a href="https://regenmag.com/category/interviews/" rel="category tag">Interviews</a></span></h3>
                    </div><!--  END "title_holder"  //-->
                                        <div class="entry_content">
                            	<p>One of the scene&#8217;s hardest working and most unifying figures, Jim Semonik speaks with <U>ReGen</U> about his latest creative output.<br />
&nbsp;<br />
<img src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikBanner.jpg" width="525" class='ngg-singlepic ngg-center' /></p>
<p>&nbsp;</p>
<p>An InterView with Jim Semonik of Distortion Productions and Red Lokust<br />
<span id="more-40387"></span><br />
By Ilker Yücel (Ilker81x)</p>
<p>Jim Semonik can truly be considered one of the patron saints of the modern industrial and harsh electro scene. With his <em>Electronic Saviors</em> compilation series, he helped to mobilize an unprecedented number of artists – from established pioneers to up-and-coming luminaries – to join in the fight to &#8220;kick cancer&#8217;s ass!&#8221; As this year marks the release of the sixth and final installment in the series, Semonik is showing no signs of slowing down as he embarks on new ventures for the betterment of both the scene and his fellow human beings – he&#8217;s expanding the <em>Electronic Saviors</em> brand with his love for <em>Transformers</em> in the <em>Respect the Prime</em> offshoot, has participated in Jeremy Frazier&#8217;s <em>Synthcore Dreams</em> project, and here he even hints at a new soundtrack tribute. One would think such a calling would be enough, but he has also done this while running his own independent imprint, Distortion Productions, as well as creating music with Aslan Faction&#8217;s Lee Lauer in Red Lokust, with this year marking the release of the band&#8217;s second album, <em>Whom the Gods Wish to Ruin, They First Drive Mad</em>. Put simply, Jim Semonik is busier than ever, so <U>ReGen Magazine</U> is privileged to have had the opportunity to speak with him about his many pursuits and how he is maintaining such a prolific pace amid the turmoil of the COVID-19 pandemic.</p>
<p>&nbsp;</p>
<p><img src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviorsLogo.jpg" width="525" class='ngg-singlepic ngg-center' /><br />
&nbsp;</p>
<p><strong>You&#8217;ve released the sixth and final volume of <em>Electronic Saviors</em>, celebrating 10 years since the first entry. Of all that <em>ES</em> has achieved, what would you say are those successes that have surprised you the most?</strong></p>
<p>            
		<div class="ngg-gallery-singlepic-image ngg-right" style="max-width: 240px">
			    	<a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviors_VIReflection.jpg"
		     title=""
             data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviors_VIReflection.jpg"
             data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_ElectronicSaviors_VIReflection.jpg"
             data-image-id="11291"
             data-title="ElectronicSaviors_VIReflection"
             data-description=""
             target='_self'
             class="shutterset_7e8a69edd07265438113499f4989d5c5">
            <img class="ngg-singlepic"
             src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/cache/ElectronicSaviors_VIReflection.jpg-nggid0511291-ngg0dyn-320x240x100-00f0w010c010r110f110r010t010.jpg"
             alt="ElectronicSaviors_VIReflection"
             title="ElectronicSaviors_VIReflection"
              width="240"               />
    	</a>
		      </div>
        <strong>Semonik</strong>: Certainly, the amount donated. After <em>ES6</em> runs its course, which will expand into 2021, we are confident that we will hit the 100K mark.  I&#8217;ve got to say though, that the collabs that happen on these things are mind blowing. We&#8217;ve got a new Flesh Field track with Ted Phelps on vocals, a Chris Connelly with Marc Heal track, FIRES with Adoration Destroyed, and if you go into past volumes, some entirely new projects like Cancerface were born. So, I&#8217;d say I&#8217;m certainly proud of the innovation and the diversity of styles that are represented.</p>
<p><strong>No pun intended, but reflecting on <em>ES</em> and the last decade, what would you say to your younger self – when you were undergoing treatments and first came up with the idea for <em>ES</em> – if given the opportunity?</strong></p>
<p><strong>Semonik</strong>: I would tell myself to not to be afraid to take the steps that were needed. I was intimidated by approaching people for tracks. In some ways, I still am because people have lives and are generally busy. I&#8217;m essentially asking for their time to devote to something new. I respect all my artists and know that free time doesn&#8217;t come easy, but you might be surprised by who will be willing to help. Though, I never got the attention of Skinny Puppy or FLA&#8230; I mean, they knew of the project because of conversations I&#8217;ve had with them, so it wasn&#8217;t for lack of trying. (Laughter)</p>
<p>&nbsp;<br />
<iframe width="525" height="120" style="position: relative; display: block; width: 525px; height: 120px;" src="//bandcamp.com/EmbeddedPlayer/v=2/album=3404047822/size=large/bgcol=333333/linkcol=2ebd35/tracklist=false/artwork=small/" allowtransparency="true" frameborder="0"></iframe><br />
&nbsp;</p>
<p><strong>For the offshoots, you&#8217;ve now released two entries in the <em>Respect the Prime</em> series (not counting the multiple versions of the first one), and the <em>Synthcore Dreams</em> soundtrack to the comic book.<br />
First of all, would you tell us about the development of these two spinoffs, how they came to be and in what ways you feel they relate to the goals and spirit of <em>Electronic Saviors</em>?</strong></p>
<p>            
		<div class="ngg-gallery-singlepic-image ngg-left" style="max-width: 160px">
			    	<a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikPortrait2019.jpg"
		     title=""
             data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikPortrait2019.jpg"
             data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikPortrait2019.jpg"
             data-image-id="11289"
             data-title="JimSemonikPortrait2019"
             data-description=""
             target='_self'
             class="shutterset_278796bb656593274f8c8b46b68f19bd">
            <img class="ngg-singlepic"
             src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/cache/JimSemonikPortrait2019.jpg-nggid0511289-ngg0dyn-320x240x100-00f0w010c010r110f110r010t010.jpg"
             alt="JimSemonikPortrait2019"
             title="JimSemonikPortrait2019"
              width="160"               />
    	</a>
		      </div>
        <strong>Semonik</strong>: Well, <em>Respect the Prime</em> is just my passion project because I love <em>Transformers</em>. In 2014, I started going to TFcons by myself. While there, I met several people who worked for IDW Comics like Casey Coller, John Paul Bove, Nick Roche, and Josh Perez among others. I&#8217;d buy stuff from their table and get sketch covers done on my blank comics. When <em>Respect the Prime</em> took shape, mainly due to a desire to share my love of industrial with my love of <em>Transformers</em> comics and lore, I asked Casey and John Paul to be involved. What resulted was my favorite thing I ever released. I want to continue the series in the same spirit as the <em>Constructed Cold</em> EP. So, for next year&#8217;s conventions, we plan on having the <em>Forged</em> EP for sale. The folks at IDW have been very supportive. John Barber himself even included a <em>Respect the Prime</em> Easter egg in one of his <U>Optimus Prime</U> comics, so I think that says it all. I have nothing but love and respect for those folks. I figured tying it in with <em>Saviors</em> and making it a series was a natural thing.<br />
<em>Synthcore Dreams</em> I was much less involved with and generally centers around Jamie Duffy and us doing something to honor him. It was all organized by Jeremy Frazier and Dave of Society Burning. They included animated versions of us in the comic book companion of it, which was a trip. It was the same team that did the <em>ES</em> comic. There is a second volume in the works too. Then there is <em>The Crow</em>&#8230;</p>
<p>&nbsp;<br />
<iframe width="525" height="120" style="position: relative; display: block; width: 525px; height: 120px;" src="//bandcamp.com/EmbeddedPlayer/v=2/album=1366017295/size=large/bgcol=333333/linkcol=4ec5ec/tracklist=false/artwork=small/" allowtransparency="true" frameborder="0"></iframe><br />
&nbsp;</p>
<p><strong>What are your ultimate hopes for each of the spinoffs? How much farther do you think they can or do you intend to take them?</strong></p>
<p><strong>Semonik</strong>: I&#8217;m not sure for <em>Synthcore</em>. I mean, if Jeremy wants to keep doing them and there is demand, we will still do them.  For <em>Prime</em>&#8230; well&#8230; as long as there are comics, there are endless original songs that can be written. I mean, I&#8217;m really proud of the <em>Constructed Cold</em> tune that I did with Panic Lift – quite possibly the catchiest song I ever wrote and James is a goddamn genius. These things sell like hotcakes at the TFcons, even to people who don&#8217;t know this kind of music. That should tell you something. We are being as accessible as an underground label can be while just being one guy with a full-time day job. So, I&#8217;ll keep doing them if people keep digging what we do. These are the ways <em>Electronic Saviors</em> will live on. So, I encourage people that just buy the boxsets, to check these out. I&#8217;ve not gotten a bad review from anyone for <em>Respect the Prime</em> in four years.</p>
<p><strong>You&#8217;re also releasing new music, having unveiled the second album from Red Lokust, <em>Whom the Gods Wish to Ruin, They First Drive Mad</em>.<br />
First of all, would you tell us about what sorts of changes/developments you and Lee Lauer sought to implement with Red Lokust since the first album?<br />
What sorts of lessons did you learn that you feel are reflected on the new album?</strong></p>
<p>            
		<div class="ngg-gallery-singlepic-image ngg-right" style="max-width: 150px">
			    	<a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/RedLokust_WtGWtRTFDM.jpg"
		     title=""
             data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/RedLokust_WtGWtRTFDM.jpg"
             data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_RedLokust_WtGWtRTFDM.jpg"
             data-image-id="11294"
             data-title="RedLokust_WtGWtRTFDM"
             data-description=""
             target='_self'
             class="shutterset_b894d33efdbcb1717afd61e319f15b16">
            <img class="ngg-singlepic"
             src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/cache/RedLokust_WtGWtRTFDM.jpg-nggid0511294-ngg0dyn-150x150x100-00f0w010c010r110f110r010t010.jpg"
             alt="RedLokust_WtGWtRTFDM"
             title="RedLokust_WtGWtRTFDM"
              width="150"               />
    	</a>
		      </div>
        <strong>Semonik</strong>: I love this new album. This is quite possibly the first record I&#8217;ve ever put out that I was 100% happy with. I think the process Lee and I have is a lot more streamlined now. When we wrote the first album, we barely knew each other. Since then, we&#8217;d toured and played a bunch of killer shows together. I think we understand each other more now because when we get together to mix, things just click into place. So, the chemistry is a lot more powerful, the production is better, etc. The first record was us sort of getting used to each other.</p>
<p><strong>How would you define your individual roles in the band? Is it as simple as one is musician, the other is vocalist? What is the working dynamic like between the two of you?<br />
How would you say your respective roles evolved from how they were when Red Lokust was first formed?</strong></p>
<p><strong>Semonik</strong>: Lee does all of the music; I only help arrange certain things. If I feel a certain sequence needs extending or repeating, I just suggest it. I do all of the lyric writing and singing. It&#8217;s pretty easy as I&#8217;ve said the chemistry is strong, but the distance can hurt sometimes. There are instances when I want to reach through the screen and be like, &#8216;no, change this.&#8217; But generally, it&#8217;s great. He sends me tunes and I write to them. It hasn&#8217;t changed much.  </p>
<p>&nbsp;<br />
<iframe width="525" height="120" style="position: relative; display: block; width: 525px; height: 120px;" src="//bandcamp.com/EmbeddedPlayer/v=2/album=4161641848/size=large/bgcol=333333/linkcol=e32c14/tracklist=false/artwork=small/" allowtransparency="true" frameborder="0"></iframe><br />
&nbsp;</p>
<p><strong>The title is very Lovecraftian, and you say the album is inspired by themes of insanity, paranoia, and anxiety. There is the quote that &#8216;in an insane world, the sane must appear insane in order to stay sane,&#8217; which is also rather Shakespearean as it relates to <U>Hamlet</U> (and <em>Alien3</em>).<br />
Anyway, forgive the digression. What inspired you to explore these themes in particular on this album?<br />
What are your thoughts on the perception of insanity in today&#8217;s world – socially, spiritually, medically, etc. What constitutes insanity in your world view?</strong></p>
<p><strong>Semonik</strong>: Short answer – I have a psychology degree.<br />
Long answer – These themes have always been of interest to me as I am an avid fan of comics, science fiction, and generally darker things. We are living in one of the most insane times in our lives. I have never seen things so out of control in this world. On one hand, we have a leader that thrives in chaos<br />
and is a pathological liar, and on the other hand, we have a virus that is killing thousands. The world as it is right now is pretty insane in my view. Every day, I think it might not get crazier than this. Then I go on social media and I turn around like Abe Simpson and head on out. I&#8217;m not sure if that answers the question or not.<br />
By the way, I&#8217;ve always been a fan of long album titles. I feel like an album should tell a story, so that&#8217;s what I do. I have some good ones lined up for what&#8217;s next.</p>
<p><strong>You knew this question would come up. What&#8217;s the status of Rein[Forced]?</strong></p>
<p><strong>Semonik</strong>: How did I know you were going to ask that? Well, here&#8217;s what I can tell you. We still owe WTII one more album, but I haven&#8217;t really talked to Turner. I think the long time in between albums killed that project along with some other things I won&#8217;t get into. However, if you picked up <em>Electronic Saviors 6</em>, you&#8217;ll notice that the second track on the first disc is a new track by us. Eric and Jon from Interface jumped onboard to write a new tune with me. We are sort of waiting to see if that pans out. So, if you guys like that track, &#8216;No Desire,&#8217; we will do an album as is my understanding. I personally love that song.</p>
<p><strong>With live music in a great deal of turmoil due to the COVID-19 pandemic – numerous tour cancellations, clubs and venues being forced to close indefinitely and perhaps permanently, etc. – what possibilities do you foresee for live music to survive or evolve in the wake of the current situation?<br />
On the other hand, a livestream obviously doesn&#8217;t hold the same power as a live show, but as it&#8217;s become part of the status quo, what sort of possibilities do you see for bands to use new and online technologies to keep music alive and maintain the excitement of audiences?<br />
Are there any plans or hopes for a Red Lokust live performance in the foreseeable future?</strong></p>
<p><strong>Semonik</strong>: Oh man, we are in trouble, aren&#8217;t we? It&#8217;s bad, though I see folks doing the livestreaming thing in quite ingenious ways. Anyone catch that Null Device set? I don&#8217;t think you&#8217;ll see Red Lokust doing that. Our show is very interactive, and also, the distance between Lee and I sort of complicates that. I&#8217;m not really set up for that type of thing and my heart wouldn&#8217;t be in it. I need to be in front of people. Red Lokust put out a new album at the worst possible time, didn&#8217;t we? But I guess I can tell you that we were supposed to play the ColdWaves Pre-Party show with some great bands who have been on <em>Saviors</em> comps.  It&#8217;s a giant bummer, but I think if we can still hang onto that for next year, we&#8217;ll have something really special lined up. I&#8217;m dying to play these new songs live. We&#8217;ll see if Dark Side of the Con happens because we are on that.<br />
I don&#8217;t know, man. It&#8217;s a terrifying time to be an artist or anyone in the entertainment business basically because we feel like we have no future.</p>
<p>&nbsp;<br />
<img src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/DistortionProductionsLogo.jpg" width="525" class='ngg-singlepic ngg-center' /><br />
&nbsp;</p>
<p><strong>On top of all of that, you&#8217;ve been running Distortion Productions. Besides the financial aspects, what have you found to be the major challenges in running a label in the digital age?<br />
What sorts of changes – both in the industry and in audiences – have you seen take place, and how do you feel you&#8217;ve responded to them in the way you run Distortion Productions?</strong></p>
<p><strong>Semonik</strong>: Yes indeed. I love the label business, though with the label essentially just being me, it presents a ton of challenges. Staying on top of all of the daily tasks that need finishing – i.e. sending out orders, getting digital releases set up, Bandcamp, my day job, social media, doing one sheets, website updating, etc. – is the most challenging because I have to eat, sleep, and find time to enjoy life and my relationship. Physical sales are the biggest change I&#8217;ve seen. I still get a fair share of them, but digital<br />
is far greater. We try to give incentives. We did those two Deathline International physical singles, the four latter discs in <em>ES6</em> are physical exclusives, and we give free gifts with orders too, so I&#8217;m always looking for ways to make my customers happy.</p>
<p>&nbsp;<br />
<iframe width="525" height="120" style="position: relative; display: block; width: 525px; height: 120px;" src="//bandcamp.com/EmbeddedPlayer/v=2/album=3979098281/size=large/bgcol=333333/linkcol=e99708/tracklist=false/artwork=small/" allowtransparency="true" frameborder="0"></iframe><br />
&nbsp;</p>
<p><strong>You were recently featured in Deathline International&#8217;s second cover of &#8216;Troops of Tomorrow.&#8217; Tell us about that, how you came to be part of it and your thoughts on the song, what it means to you?</strong></p>
<p><strong>Semonik</strong>: I can&#8217;t begin to comprehend it. When Christian asked me to contribute, obviously I didn&#8217;t hesitate. I love him like a brother, and I&#8217;ve loved DLI since my college days, and COP was the first label I ever repped for. We live in difficult times. To be able to be a part of something so monumental is nothing short of amazing. The Black Lives Matter movement is very important, so any contribution to help was a no-brainer. The funds going to the ACLU is a wonderful thing. You only live once, so a meaningful contribution like this with so many awesome people that I&#8217;ve idolized over the years is an honor.</p>
<p><strong>What&#8217;s next for you?</strong></p>
<p>            
		<div class="ngg-gallery-singlepic-image ngg-left" style="max-width: 320px">
			    	<a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikIY2019.jpg"
		     title=""
             data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikIY2019.jpg"
             data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikIY2019.jpg"
             data-image-id="11290"
             data-title="JimSemonikIY2019"
             data-description=""
             target='_self'
             class="shutterset_6b811162c35147618f9516d363ad647e">
            <img class="ngg-singlepic"
             src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/cache/JimSemonikIY2019.jpg-nggid0511290-ngg0dyn-320x240x100-00f0w010c010r110f110r010t010.jpg"
             alt="JimSemonikIY2019"
             title="JimSemonikIY2019"
              width="320"               />
    	</a>
		      </div>
        <strong>Semonik</strong>: I literally just sent off the Red Lokust &#8216;Madman&#8217; single for mastering, which has some killer versions by Ashbury Heights, Tragic Impulse, SPANKTHENUN, Third Realm, and my buddy Dan from Glass Apple Bonzai. Distortion has some killer releases lined up for Fall, including some Steven Archer projects and I plan on starting on <em>Respect the Prime: The Forged EP</em>, then <em>The Crow</em> soundtrack. The work never ends over here. Stay tuned for a big donation at Christmas time.</p>
<p>&nbsp;</p>
<p>Red Lokust<br />
<a href="http://www.red-lokust.com">Website</a>, <a href="https://www.facebook.com/Red-Lokust-734889406642643">Facebook</a>, <a href="https://redlokust.bandcamp.com">Bandcamp</a><br />
Electronic Saviors<br />
<a href="http://electronicsaviors.com">Website</a>, <a href="https://www.facebook.com/electronicsaviors">Facebook</a>, <a href="https://twitter.com/ESaviors23">Twitter</a><br />
Distortion Productions<br />
<a href="http://www.distortionprod.com">Website</a>, <a href="https://www.facebook.com/distortionproductions">Facebook</a>, <a href="https://twitter.com/distortionprod">Twitter</a>, <a href="http://distortionprod.bandcamp.com">Bandcamp</a>, <a href="https://www.youtube.com/channel/UCsdRZD6_bqeRAtJr1P95N5g">YouTube</a></p>
<p>&nbsp;</p>
<p>Photography provided courtesy of Jim Semonik</p>
<p>&nbsp;</p>
<!-- index.php -->
<div
	class="ngg-galleryoverview"
	id="ngg-gallery-03862a11f33faa627cc97793b4dc5b6d-1">

    	<div class="slideshowlink">
        <a href='https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/nggallery/slideshow'>[Show as slideshow]</a>
		
	</div>
			<!-- Thumbnails -->
				<div id="ngg-image-0" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikBanner.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikBanner.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikBanner.jpg"
               data-image-id="11288"
               data-title="JimSemonikBanner"
               data-description=""
               data-image-slug="jimsemonikbanner"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="JimSemonikBanner"
                    alt="JimSemonikBanner"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikBanner.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-1" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikPortrait2019.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikPortrait2019.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikPortrait2019.jpg"
               data-image-id="11289"
               data-title="JimSemonikPortrait2019"
               data-description=""
               data-image-slug="jimsemonikportrait2019"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="JimSemonikPortrait2019"
                    alt="JimSemonikPortrait2019"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikPortrait2019.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-2" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikIY2019.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/JimSemonikIY2019.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikIY2019.jpg"
               data-image-id="11290"
               data-title="JimSemonikIY2019"
               data-description=""
               data-image-slug="jimsemonikiy2019"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="JimSemonikIY2019"
                    alt="JimSemonikIY2019"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_JimSemonikIY2019.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-3" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviors_VIReflection.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviors_VIReflection.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_ElectronicSaviors_VIReflection.jpg"
               data-image-id="11291"
               data-title="ElectronicSaviors_VIReflection"
               data-description=""
               data-image-slug="electronicsaviors_vireflection"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="ElectronicSaviors_VIReflection"
                    alt="ElectronicSaviors_VIReflection"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_ElectronicSaviors_VIReflection.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-4" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviorsLogo.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/ElectronicSaviorsLogo.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_ElectronicSaviorsLogo.jpg"
               data-image-id="11292"
               data-title="ElectronicSaviorsLogo"
               data-description=""
               data-image-slug="electronicsaviorslogo"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="ElectronicSaviorsLogo"
                    alt="ElectronicSaviorsLogo"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_ElectronicSaviorsLogo.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-5" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/DistortionProductionsLogo.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/DistortionProductionsLogo.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_DistortionProductionsLogo.jpg"
               data-image-id="11293"
               data-title="DistortionProductionsLogo"
               data-description=""
               data-image-slug="distortionproductionslogo"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="DistortionProductionsLogo"
                    alt="DistortionProductionsLogo"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_DistortionProductionsLogo.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-6" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/RedLokust_WtGWtRTFDM.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/RedLokust_WtGWtRTFDM.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_RedLokust_WtGWtRTFDM.jpg"
               data-image-id="11294"
               data-title="RedLokust_WtGWtRTFDM"
               data-description=""
               data-image-slug="redlokust_wtgwtrtfdm"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="RedLokust_WtGWtRTFDM"
                    alt="RedLokust_WtGWtRTFDM"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_RedLokust_WtGWtRTFDM.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
				<div id="ngg-image-7" class="ngg-gallery-thumbnail-box" >
				        <div class="ngg-gallery-thumbnail">
            <a href="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/DeathlineInt_TroopsofTomorrow.jpg"
               title=""
               data-src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/DeathlineInt_TroopsofTomorrow.jpg"
               data-thumbnail="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_DeathlineInt_TroopsofTomorrow.jpg"
               data-image-id="11295"
               data-title="DeathlineInt_TroopsofTomorrow"
               data-description=""
               data-image-slug="deathlineint_troopsoftomorrow"
               class="shutterset_03862a11f33faa627cc97793b4dc5b6d">
                <img
                    title="DeathlineInt_TroopsofTomorrow"
                    alt="DeathlineInt_TroopsofTomorrow"
                    src="https://regenmag.com/wp-content/gallery/jim-semonik-interview-2020-08-06/thumbs/thumbs_DeathlineInt_TroopsofTomorrow.jpg"
                    width="100"
                    height="75"
                    style="max-width:100%;"
                />
            </a>
        </div>
							</div> 
			
        
		
		<div class="ngg-clear"></div>
	</div>

<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-40387" class="share-facebook sd-button share-icon no-text" href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-40387" class="share-twitter sd-button share-icon no-text" href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://regenmag.com/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>                                                  </div><!--  END "entry_content"  //-->
                    <div class="comments">
                    
<!-- You can start editing here. -->


			<!-- If comments are open, but there are no comments. -->

	 


<div id="respond">

<h3>Leave a Comment</h3>

<div class="cancel-comment-reply">
	<small><a rel="nofollow" id="cancel-comment-reply-link" href="/interviews/interview-jim-semonik-reflecting-and-forging-new-paths/#respond" style="display:none;">Click here to cancel reply.</a></small>
</div>


<form action="https://regenmag.com/wp-comments-post.php" method="post" id="commentform">


<p><input type="text" name="author" id="author" value="" size="22" tabindex="1" aria-required='true' />
<label for="author"><small>Name (required)</small></label></p>

<p><input type="text" name="email" id="email" value="" size="22" tabindex="2" aria-required='true' />
<label for="email"><small>Mail (will not be published) (required)</small></label></p>

<p><input type="text" name="url" id="url" value="" size="22" tabindex="3" />
<label for="url"><small>Website</small></label></p>


<!--<p><small><strong>XHTML:</strong> You can use these tags: <code>&lt;a href=&quot;&quot; title=&quot;&quot;&gt; &lt;abbr title=&quot;&quot;&gt; &lt;acronym title=&quot;&quot;&gt; &lt;b&gt; &lt;blockquote cite=&quot;&quot;&gt; &lt;cite&gt; &lt;code&gt; &lt;del datetime=&quot;&quot;&gt; &lt;em&gt; &lt;i&gt; &lt;q cite=&quot;&quot;&gt; &lt;s&gt; &lt;strike&gt; &lt;strong&gt; </code></small></p>-->

<p><textarea name="comment" id="comment" cols="100%" rows="10" tabindex="4"></textarea></p>

<p><input name="submit" type="submit" id="submit" tabindex="5" value="Submit Comment" />
<input type='hidden' name='comment_post_ID' value='40387' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="743a1aada0" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="152"/></p>
<div id="captchaImgDiv">

<div class="si_captcha_small"><img id="si_image_com" src="https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix=GcB0kHFLfrmgpKrF" width="132" height="45" alt="CAPTCHA" title="CAPTCHA" />
    <input id="si_code_com" name="si_code_com" type="hidden"  value="GcB0kHFLfrmgpKrF" />
    <div id="si_refresh_com">
<a href="#" rel="nofollow" title="Refresh" onclick="si_captcha_refresh('si_image_com','com','/wp-content/plugins/si-captcha-for-wordpress/captcha','https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/securimage_show.php?si_sm_captcha=1&amp;si_form_id=com&amp;prefix='); return false;">
      <img class="si_captcha_refresh" src="https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/images/refresh.png" width="22" height="20" alt="Refresh" onclick="this.blur();" /></a>
  </div>
  </div>

<p id="si_captcha_code_p">
<input id="si_captcha_code" name="si_captcha_code" type="text" />
<label for="si_captcha_code" >CAPTCHA Code</label><span class="required"> *</span>
</p>
</div>
      <script type='text/javascript'>
          var sUrlInput = document.getElementById("comment");
                  var oParent = sUrlInput.parentNode;
          var sSubstitue = document.getElementById("captchaImgDiv");
                  oParent.appendChild(sSubstitue, sUrlInput);
      </script>
            <noscript>
          <style type='text/css'>#submit {display:none;}</style><br />           <input name="submit" type="submit" id="submit-alt" tabindex="6" value="Submit Comment" />
          </noscript>
  
</form>


</div>
                    </div>
              </div><!--  END "entry"  //-->
 

            
          </div><!--  END "inner_content"  //-->
          
     
        
          <div id="sidebar_home">
          <div class="widget">	<h3 class="widget_title">Advertisement</h3><div class="g g-1"><div class="g-single a-77"><a href="https://www.youtube.com/watch?v=xwpwoKy3XtI" target="_blank"><img src="https://regenmag.com/wp-content/gallery/ads/Snuttock_300x600Stay.gif" /></a></div></div></div><div class="widget">	<h3 class="widget_title">Spotify</h3>			<div class="textwidget"><p><iframe title="Spotify Embed: Female Voices Vol. 1" allowtransparency="true" frameborder="0" allow="encrypted-media" src="https://open.spotify.com/embed/playlist/5EHhQR6UOHwCgaaMpw07VS"></iframe></p>
</div>
		</div><div class="widget">	<h3 class="widget_title">Newsletter</h3><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.8 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-20737 mc4wp-form-basic" method="post" data-id="20737" data-name="Default sign-up form" ><div class="mc4wp-form-fields"><center>
	<h2>Sign Up for the ReGen Newsletter:</h2>
	<input type="email" name="EMAIL" placeholder="Your email address" required />
<br>
<p>
	<input type="submit" value="Submit" />
</p>
</center></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1596766903" /><input type="hidden" name="_mc4wp_form_id" value="20737" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin --></div><div class="widget">	<h3 class="widget_title">Donate to Regen</h3><p>ReGen is a 100% volunteer run publication. However, there are costs involved in running a website - we need your help! Please donate so that we may continue to provide the best possible content to ReGenerate Your Mind!</p>
<!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="ilker@regenmag.com" />
        <input type="hidden" name="item_name" value="If you enjoy our content, please consider making a donation to ReGen to assist us in covering expenses. We are a 100% volunteer run publication." />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donate_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" />
    </div>
</form>
<!-- End PayPal Donations -->
</div><div class="widget">	<h3 class="widget_title">Recent ReViews</h3><ul id="category-posts-15-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/reviews/review-red-lokust-whom-the-gods-wish-to-ruin-they-first-drive-mad/" rel="bookmark">ReView: Red Lokust &#8211; Whom the Gods Wish to Ruin, They First Drive Mad</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/reviews/review-kmfdm-in-dub/" rel="bookmark">ReView: KMFDM &#8211; IN DUB</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/reviews/review-ganser-just-look-at-that-sky/" rel="bookmark">ReView: Ganser &#8211; Just Look At That Sky</a></div></li></ul>
</div><div class="widget">	<h3 class="widget_title">Recent Inteviews</h3><ul id="category-posts-16-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/interviews/interview-system-syn-an-emotional-rebirth/" rel="bookmark">InterView: System Syn &#8211; An Emotional Rebirth</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/interviews/interview-snog-the-stockholm-syndrome-generation/" rel="bookmark">InterView: SNOG &#8211; The Stockholm Syndrome Generation</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/interviews/interview-51-peg-turning-their-backs-on-conformity/" rel="bookmark">InterView: 51 Peg &#8211; Turning their Backs on Conformity</a></div></li></ul>
</div><div class="widget">	<h3 class="widget_title">Recent News</h3><ul id="category-posts-17-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/reptoid-announces-debut-album-on-learning-curve-records/" rel="bookmark">Reptoid announces debut album on Learning Curve Records</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/regen-magazine-spotify-playlist-female-voices-vol-1/" rel="bookmark">ReGen Magazine &#8211; Spotify Playlist: Female Voices, Vol. 1</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/angelspit-launches-kickstarter-campaign-for-ninth-album-reaches-goal-within-four-hours/" rel="bookmark">Angelspit launches Kickstarter campaign for ninth album, reaches goal within four hours</a></div></li></ul>
</div><div class="widget">	<h3 class="widget_title">Recent Blogs</h3><ul id="category-posts-18-internal" class="category-posts-internal">
<li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/news/regen-magazine-supports-blacklivesmatter/" rel="bookmark">ReGen Magazine supports #BlackLivesMatter</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/blog/showreviews/photo-archive-stoneburner-morgue-vvitch-in-kansas-city-mo-2019/" rel="bookmark">Photo Archive &#8211; Stoneburner / Morgue VVitch in Kansas City, MO, 2019</a></div></li><li class='cat-post-item'><div><a class="cat-post-title" href="https://regenmag.com/blog/photo-archive-pigface-project-44-i-ya-toyah-gaelynn-lea-in-kansas-city-mo-2019/" rel="bookmark">Photo Archive &#8211; Pigface / Project .44 / I Ya Toyah / Gaelynn Lea in Kansas City, MO, 2019</a></div></li></ul>
</div>  
          </div><!--  END "sidebar_home"  //-->
          
    
        </div><!--  END "content_wrap"  //-->
    </div><!--  END "container"  //-->


<div id="footer" class="clearfix">
    <div id="footer_left"></div>
    <div id="footer_right"><a href="https://regenmag.com"><img src="https://regenmag.com/images/regenlogoblue_x35.png" alt="ReGen Magazine" /></a></div>
</div>
<div id="footer_bottom" class="clearfix"></div><!--  END "footer"  //-->

</div><!--  END "wrapper"  //-->
<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://regenmag.com/wp-includes/js/comment-reply.min.js?ver=5.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/regenmag.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/regenmag.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://regenmag.com/wp-includes/js/wp-embed.min.js?ver=5.4.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var photocrati_ajax = {"url":"https:\/\/regenmag.com\/index.php?photocrati_ajax=1","wp_home_url":"https:\/\/regenmag.com","wp_site_url":"https:\/\/regenmag.com","wp_root_url":"https:\/\/regenmag.com","wp_plugins_url":"https:\/\/regenmag.com\/wp-content\/plugins","wp_content_url":"https:\/\/regenmag.com\/wp-content","wp_includes_url":"https:\/\/regenmag.com\/wp-includes\/","ngg_param_slug":"nggallery"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/ajax/static/ajax.min.js?ver=3.3.5'></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_gallery_display/static/common.js?ver=3.3.5'></script>
<script type='text/javascript'>
            var nggLastTimeoutVal = 1000;

			var nggRetryFailedImage = function(img) {
				setTimeout(function(){
					img.src = img.src;
				}, nggLastTimeoutVal);
			
				nggLastTimeoutVal += 500;
			}
        

            var nggLastTimeoutVal = 1000;

			var nggRetryFailedImage = function(img) {
				setTimeout(function(){
					img.src = img.src;
				}, nggLastTimeoutVal);
			
				nggLastTimeoutVal += 500;
			}
        

            var nggLastTimeoutVal = 1000;

			var nggRetryFailedImage = function(img) {
				setTimeout(function(){
					img.src = img.src;
				}, nggLastTimeoutVal);
			
				nggLastTimeoutVal += 500;
			}
        

            var nggLastTimeoutVal = 1000;

			var nggRetryFailedImage = function(img) {
				setTimeout(function(){
					img.src = img.src;
				}, nggLastTimeoutVal);
			
				nggLastTimeoutVal += 500;
			}
        

            var nggLastTimeoutVal = 1000;

			var nggRetryFailedImage = function(img) {
				setTimeout(function(){
					img.src = img.src;
				}, nggLastTimeoutVal);
			
				nggLastTimeoutVal += 500;
			}
        
</script>
<script type='text/javascript'>
/* <![CDATA[ */

var nextgen_shutter_i18n = {"msgLoading":"L O A D I N G","msgClose":"Click to Close"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/lightbox_context.js?ver=3.3.5'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/shutter/shutter.js?ver=3.3.5'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/lightbox/static/shutter/nextgen_shutter.js?ver=3.3.5'></script>
<script type='text/javascript' src='https://use.fontawesome.com/releases/v5.3.1/js/v4-shims.js?ver=5.3.1'></script>
<script type='text/javascript' defer integrity="sha384-kW+oWsYx3YpxvjtZjFXqazFpA7UP/MbiY4jvs+RWZo2+N94PFZ36T6TFkc9O3qoB" crossorigin="anonymous" data-auto-replace-svg="false" data-keep-original-source="false" data-search-pseudo-elements src='https://use.fontawesome.com/releases/v5.3.1/js/all.js?ver=5.3.1'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/thumbnails/nextgen_basic_thumbnails.js?ver=3.3.5'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/nextgen-gallery/products/photocrati_nextgen/modules/nextgen_basic_gallery/static/thumbnails/ajax_pagination.js?ver=3.3.5'></script>
<script async="async" type='text/javascript' src='https://regenmag.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.6'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.min.js?ver=4.7.8'></script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/si-captcha-for-wordpress/captcha/si_captcha.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://regenmag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.6.1'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<a rel="nofollow" style="display:none;" href="https://regenmag.com/?blackhole=4f4ce631c9" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/regenmag.com\/interviews\/interview-jim-semonik-reflecting-and-forging-new-paths\/":40387};
	</script>
				<script>"undefined"!=typeof jQuery&&jQuery(document).ready(function(){"objectFit"in document.documentElement.style==!1&&(jQuery(".cat-post-item figure").removeClass("cat-post-crop"),jQuery(".cat-post-item figure").addClass("cat-post-crop-not-supported")),(document.documentMode||/Edge/.test(navigator.userAgent))&&(jQuery(".cat-post-item figure img").height("+=1"),window.setTimeout(function(){jQuery(".cat-post-item figure img").height("-=1")},0))});</script><script type='text/javascript' src='https://stats.wp.com/e-202032.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'51468280',post:'40387',tz:'-4',srv:'regenmag.com'} ]);
	_stq.push([ 'clickTrackerInit', '51468280', '40387' ]);
</script>
 
</body>
</html>
